Saros Compatibility

Learn here about copatibility issues of Saros.
 
 

 

Eclipse plugins tested with Saros  

Saros is compatible with any well-behaved language-plugin whose editor is based on Eclipse's standard text editor class.
The following table lists language plugins for which we have explicitly verified that they work with Saros.
The version numbers indicate the latest version tested.

 

Plugin/Product
Language
Version
Eclipse version
Saros version tested
Supported
Open Bugs
PHP, Ruby, Python, Javascript
2.0
Eclipse 3.5 Galileo
9.12.4
Yes
 
HTML, CSS, ERB
2.0
Eclipse 3.5 Galileo
9.12.4
No
C/C++
6.0.1
Eclipse 3.5 Galileo
9.12.4
Yes
 
C/C++, PHP, Ruby & Rails, Python, Perl
1.2.2.2
Eclipse 3.5 Galileo
9.12.4
No
 
Perl
0.6.35
Eclipse 3.5 Galileo
9.12.4
Yes
 
Java
3.5
Eclipse 3.5 Galileo
9.12.4
Yes
 
PHP
1.2.1
Eclipse 3.4 Ganymede
9.6.23
Yes
 
PHP
2.1.0
Eclipse 3.5 Galileo
9.12.4
Yes
 
Python
1.5.4
Eclipse 3.5 Galileo
9.12.4
Yes
 
PHP, TypoScript
1.0.3
Eclipse 3.5 Galileo
9.12.4
No
MXML, ActionScript™, and CSS
3
Eclipse 3.5 Galileo
9.12.4
No
 
If your favorite plug-in is not supported feel free to report a bug or tell us at dpp-devel@lists.sourceforge.net.
 
 
 
 

Types of incompatibility

Generally speaking, the following types of problems can potentially occur when other plugins are combined with Saros:
  • The other plugin requires versions of Eclipse with which Saros is not compatible
  • Minor problems from conflicting markup/highlighting behavior, e.g. heavy use of the annotation bar.
  • Various kinds of problems may occur if other plug-ins (or any sort of firewall software outside of Eclipse) intercept network traffic.
  • Integrity problems may occur if other software modifies files without notifying Eclipse. Well-behaved plugins will not do this. (However, Saros includes a consistency watchdog that will often recognize and repair such situations quickly.)