Environment Requirements


Requirements for building Saros

We develop three different versions of Saros, two of which are IDE plugins (one for Eclipse, called Saros/E, and another for IntelliJ IDEA, called Saros/I), and a third which is a stand-alone Saros server (Saros/Server). All of these use a common core.

Currently, the two IDE versions make use of the respective UI frameworks, which are SWT for Eclipse and Swing for IntelliJ. We are, however, in the process of developing a common, HTML-based user interface for Saros.

The specific requirements for your development environment depend on which parts of Saros you want to change.


You need a Java 7 JDK. Java 8 won't work.

Saros for Eclipse

Download and install Eclipse Classic 3.7.2.

Reasons for using Eclipse 3.7

  • This manual was only tested with this version.
  • For testing purposes, we use SWTBot 2.0.5 which does not support Eclipse versions newer than 3.x. Although the more recent SWTBot 2.1.2 is said to support newer versions, we did not succeed in migrating yet.
  • Different Eclipse versions use different auto-format mechanisms, rendering the whole idea of auto useless.

Instead of Eclipse Classic, you can use other Eclipse distributions, e.g. in case you already have an Eclipse installed and want to reuse it. Here are the requirements for your Eclipse setup:

  • Eclipse Plug-in Development Environment (org.eclipse.pde)
  • Eclipse Graphical Editing Framework GEF (update site, install version 3.7.2)
  • Subclipse (needed for building Saros, installation instructions)

Saros for IntelliJ IDEA

See here for more information on Saros/I development.

Saros for Netbeans

See here for more information on Saros/N development.

The new HTML GUI

Building Saros/Server

Take part in our collaborative workflow

If your environment fulfills these requirements, you may continue reading about our workflow.